Creating a circular zip code Christmas ornament in Cuttle
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1. Create a new parameter | 7. Navigate to the of 13. Create a new parameter| 20. Change the second 0 to
called OrnDiameter and Circle 2, select the called OuterDia and -OrnDiameter/2+0.125
set the value to 3.75 and select set the value to so the string reads

o 7 | [= =] InsideDia+0.25 Vec(0,-OrnDiameter/2+0.125)

z = m i IIJ i o d position vec(@.08, -OrnDiameter/2+.125

Extract as Parameter o ;

2. Drag a Circle and place . 21. gglelct?)Clrcle 1and
the center of it at the 14. Drag a Circle and place ircle
center of the Canvas 8. Change the to be the center of it at the ; G

InsideDia center of the Canvas Circle 3
scale InsideDia Ci"d‘é 2 /
0.1875 .
Circle 1 S
9. Click once in the Y origin
field so it looks like below 22. Select

Vec(0,0)

scale InsideDia

Modify>Boolean Union

23. Select Group 1

Group 1 Bl Boolean Union
Circe 3 (?)( /S
Circle1 (i) S

origin vec(o, 0)
3. Navigate to the of
Circle 1, select the 10. Change the second 0 to | 15. Navigate to the of
and select 0.5 so the string reads Circle 3, select the
= s | Vec(0,0.5) and select
origin Vec(@, 0.5) = =
Extract as Parameter 11. Click once in the
Y position field so it looks Extract as Parameter
4. Change the to be like belowq-» VeC(Q’O)
OrnDiameter ——— 16. Change the to be
I,ule OraDiameter I position Vec(0, 0) OuterDia
5. Create a new parameter |12. Change the second 0 to scale Outerdia
called InsideDia and -OrnDiameter/2 so the 0.4375

set the value to 0.1875

InsideDia @.1875

string reads
Vec(0,-OrnDiameter/2)

vec(@, -OrnDiameter/2)

position

-1.875

24. Check Stroke, change
color to RED and select
hairline

J Stroke
@

color

hairline

17. Click once in the Y origin
field so it looks like below
Vec(0,0)

6. Drag a Circle and place
the center of it at the
center of the Canvas

Should look like below

origin Vec(@, 0)

25. With Group 1 still
selected, go to
Modify>Round Corners
and change the radius to
0.06

18. Change the second 0
to 0.5 so the string
reads Vec(0,0.5)

Help Share
|

origin Vvec(@, 0.5)

19. Click once in the Y
position field so it looks
like below - Vec(0,0)

radius 0.06

26. Select Circle 2

0.000 ¥ 9.000

position Vec(@, 0)

p1 /) Mg Boolean Union /| -\ Round Corners
S

Circle 1 s
Circle 2 S
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27. Check Stroke, change
color to BLUE and
select hairline

® / Stroke
color .
hairline

31. Create a new parameter
called State and select
the and change
the Parameter type to
Select. Screen should
look like below.

28. Double click on Circle 2
and Change it to InnerDia

Circle2 i1 JS

S

InnerDia (i~

32. This is going to be a
State picklist. | found a
state list on the internet.
Delete the words first
and second, and replace
them with a state list

and select Set Options

29. Double click on Group 1
and change it to
Perimeter and collapse
the arrow

I | Group 1 /| Wl Boolean Union J 7 Round Corners I

Y Round Corners

Perimeter |/ | Bl Boolean Union
InnerDia S

Screen should look like below

Perimeter (/S ‘ Boolean Union | Y Round Corners
InnerDia (i*)(/
Untitled Project
OrnDiameter 3.75
InsideDia .1875
InsideDia+@.
O]

Edit Options

Texas

Utah

Vermont

Virginia

Washington

West Virginia

Wisconsin -
Wyoming

Cancel

35. Create a new parameter
called BimText and select
the 3 dots and change the
Parameter type toText. Then
change Aa to home for the
holidays

39. With Circle 5 selected,
change the size to
OrnDiameter/12

size 54 pt «

| size OrnDiameter/12 |

40. With Circle 5 selected,
change the verticalAlign
from middle to Top

| verticalAlign top v |

]

| BtText

| Btmlext home for the holidays

36. Drag out Text Around
Circle (Top) and place it at
the center of the canvas

41. With Circle 5 selected,
change the letterSpacing
from 0.0% to 0.770. It
should look like 11%

l letterSpacing I

|\c'le‘3:mu“g

0.110 |

Screen should look like below

42. With Circle 5 selected,
uncheck the stroke, check
the fill, and change the fill
to BLACK.

L T; i
8 7 stroke - n
|

hairline V|

color

33. Create a new parameter
called TopText and select
the and change the
Parameter type toText.
Then change Aa to

there’s no place like

Untitled Project
OrnDiameter
InsideDia ©.1875

InsideDia+.25

City Albany

State v

30. Create a new parameter
called City and select
the and change
the Parameter type to
Text. Then change Aa to

Albany

City 2}

City Aa

City Albany

37. With Circle 5 selected,
change the scale to
OrnDiameter

J | & Text Along Path |

| Circle’ 5 i°

’ scale

scale ornDiameter

4.00 in v & ]

there's no place like

Screen should look like below

)

5 NO PLy
& Cé\(/‘
S T

34. Create a new parameter
called ZijpCode and select
the and change the
Parameter type toText.
Then change Aa to 31721

38. With Circle 5 selected,

select the and
Edit Expression and then
change it to

TopText.toUpperCase();
Note: This changes the text to

| UPPER CASE
text [Text Around Cirde

TopText. toUppercase();

| text

43. Drag out Text Around
Circle (Bottom) and
place it at the center of
the canvas
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Screen should look like below

Screen should look like below

54. With Path 6 selected,

59. Select Custom
Warped Text and drag
it to the Canvas Origin.

2 uncheck the stroke,
: Nov PL,q check the fill, and
< NO PLg 7 -
i Q&.SN L"Qe ,_Q&s Qc( change the fill to BLACK.
& %\ & %
i “\ i *\ O @ Fil
i;‘ ! S Stroke
= % v : color B
\@é\ :\O?. o
i Aop e o) hairline
44 . With Circle 6 selected,| 50. Select Custom @ Fil
change the scale to Warped Text and type color
OrnDiameter drag it to the color B
| Circle 6 :° | /| °5° Text Along Path | Canvas Orlgln
[ s Stroke

":(.d‘e 4.00 in v & l

Custom

Custom a

Custom Warped Text

60. With Path 7 selected,
select the and
Edit Expression and
then change text to
ZipCode

Path8 i’ | @) Warped Text

text ZipCode

31721

e 55. With Path 6 selected,
Custom select Edit>Duplicate
45. With Circle 6 selected, View Modify Help Share
select the 3 dots and Undo
Edit Expression and then
change it to
BtmText.toUpperCase(); custom - Select Al
| text [Text Around Circle | CUt
Copy
Paste
pr———— Custom Warped Text
46. With Circle 6 selected, | 51. With Path 6 selected, 56. With Path 7 selected,

change the size to
OrnDiameter/12

change the position to
Vec(0, -OrnDiameter/2*.45)

size 54 pt v

Path6  i” | @) Warped Text

change the position to
Vec(0, OrnDiameter/2*.45)

Path7 i’ @ Warped Text

ornDiameter/12 ‘

a.00

8.00 |

47. With Circle 6 selected,
change the verticalAlign
from middle to Bottom

| verticalAlign v ‘

verticalAlign bottom v

position Vec(®, -OrnDiameter/2*.45)

position Vec(@, OrnDiameter/2%.45)

Vec (2] 9.84375

61. With Path 7 selected,
change the font from
Alpa Slab One (regular
to Alkalami (regular)

Alfa Slab One (regular) i |

[=

Alkalami (regular) ~ |

48. With Circle 6 selected,
change the letterSpacing
from 0.0% to 0.710. It
should look like 11%

l letterSpacing l

52. With Path 6 selected,
select the and
Edit Expression and
then change it to City

Path6 ’ | @) Warped Text

|\e‘.le‘5:m’.\".<_.] e.110 |

text city

57. With Path 7 selected,
change the State from
Alabama to Georgia

| State v |
[ ; |

Albany

49. With Circle 6 selected,
uncheck the stroke, check
the fill, and change the fill
to BLACK.

o -5.
g s

color [ ]

53. With Path 6 selected,
change the font from Alpa
Slab One (regular) to
Send Flowers (regular)

Alfa Slab One (regular) - |

hairline

Send Flowers (regular) bt |

58. With Path 7 selected,
change text from City to
State

text

city

Albany

text State

Georgia

62. With Path 7 selected,
uncheck the stroke,
check the fill, and
change the fill to BLACK.

L] @ Fill
S Stroke

color

SN

hairline

@ ril
type colo v

color

(] / stroke
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Screen looks like below

op
Q&SN “er %
C/‘Mgango %

31721
QE@@%QML

OR THE \"0

69. Change the
displacement to
Vec(0,-0.003)

I displacement

displacement Vec(0,-0.003)

74. Select the emoji and

pick the emoji you want.

You can search for an
emoji by keying in Tree
in the search box and
selecting the tree

The following are housekeeping
steps that will make it easier to
edit if you want to make some
changes.

78. Double click on Circle 5
and change it to TopText

63. Select the Line, and

highlighted in

70. Change the EmDJI - . Circle 5 { ._To“TextAloﬂg Path |
repetltlons to 3 | TopText (1”@ 8¢ Text Along Path |
repetitions <

emojl @ 79. Double click on Circle 6
repetitions . and change it to BimText

= | Circle 6 i @) °5° Text Along Path |

| Q tree]

71. With Line 1 selected,

Search Results

K LEPS

| BtmText (1”@ °&° Text Along Path |

drag it somewhere on select
the Canvas. Modify>Mirror Repeat
Lines & Curves  MORE > Help Share

e

72. Change point2 to
Vec(1,0) and should
look like below

75. With Emoji 1 selected,
change the position to

Vec(-OrnDiameter/2*0.765,0)

80. Double click on Path 6
and change it to City

| Path6 i° @] Warped Text

City (" @ Warped Text

64. With Line 1 selected, | [mn Emoji1 " @
change point1 to
. 3 point2 Vec(j_, e) position 0.00 0.00 |
Vec(OrnDiameter/2.25, -OrnDiameter/7.75)
pasition Vec (-OrnDiameter/2*0.765, @.00)
. point2 1.008 2.00 | y 1.43437 |
Line1 J/
| | Screen looks like below 76. With Emoji 1 selected,

|.,m,—w

Vec (OrnDiameter/2.25, -OrnDiameter/7.75) ‘

81. Double click on Path 7
and change it to State

| Path7 1”1 @) Warped Text

State (1”@ Warped Text

65. With Line 1 selected,
change point2 to
Vec(-OrnDiameter/2.25, -OrmDiameter/7.75)

Line1 JS

||..‘inl2 -1.25 -1.60 |

|uu-: vec(-ornDiameter/2.25, -OrnDiameter/7.75) |

QS"S o PLAQ‘ )
“
& Atbary %

<¢
ry
OR THE WO

31721

66. With Line 1 selected,
change the stroke color

73. Drag Emoji out and
place it at the

uncheck the stroke,
check the fill, and

change the fill to BLACK.

82. Double click on Path 8
and change it to ZipCode

| Path8 i’ @) Warped Text

ZipCode ()@ Warped Text

L] @ Fil
S Stroke
color

o

hairline

83. Double click on Line 1
and change it to
DividingLines

", Linear Repeat | ¢ Mirror Repeat |

| Line 1

[F\md nglines ", Linear Repeat ' 9 Mirror Repeat ]

@ Fil

type colg v
color .

(O s Stroke

84. Double click on Emoiji 1
and change it to Trees

(] ’ Mirror Repeatl

| Emaji1 &’

| Trees 17 @) W Mirror Repeat |

to and hairline Canvas Origin
() @Fil EFT"IG_ji
S Stroke
color |:|
hairline

67. With Line 1 selected,
select
Modify>Linear Repeat

Help Share

¥ Mirror Re peat

77. With Emoiji 1 selected,
select
Modify>Mirror Repeat

Emoji1 " @

Help Share

After building the ornament
using 3.75” diameter as a
reference, | noticed that the
text and emojis didn’t scale
well if | reduced the
diameter of the ornament.

| came up with a Scale
parameter that seems to
work. See next page.
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85. Create a new parameter
called Scale and set the
value to
OrnDiameter*.53334/2

| ornDiameter*.53334/2 |

86. Set the scale for Trees,
ZipCode, State, and City to
Scale

rror Repeat

86. Set the scale for each:
Trees, ZipCode, State,
and City to Scale

Mirror Repeat

87. Create a new parameter called _info and set the
value to

console.info(

‘Overall Size is: ${OrmDiameter}" x ${OrmDiameter+InsideDia+

0.125}" and hole size is: ${InsideDia}"" );

konsole.im‘o(
“Ooverall Size is: ${OrnDiameter]}” x ${OrnDiameter+InsideDia+
8.125}" and hole size is: ${InsideDia}"" );

88. Create a new parameter called _filename and under
Component A and set it to
‘Circular_Zip_Code_Ornament_${City} ${State} ${ZipCode}

Component A e

“Circular_Zip_Code_Ornament_${City} ${State} e
_${ZipCode}"

89. Rename the project to
Circular_Zip_Code_Christmas_Ornament

Circular_Zip_Code_Christmas_Ornament

Found out that City and State need to be flattened.

91. Select City and then 92. Select State and then
Modify>Flatten Modify>Flatten

|P5tate i” 1@ Warped Text

» City I’ | @] Warped Text

Help Share v Help Share v
93. Select Read Me 94. Click in field and add
Component A
Read Me

Component | Project
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